Desktop software hitting WooCommerce API way too frequently

  • WooPOS is hitting the WooCommerce API multiple times per second causing the web server to slow way down.

    We were able to adjust this setting (screenshot) but it only allows one digit in that field so the max delay is 9 seconds.

    Has anyone found a way to throttle these requests?



    You can get the upgrade to extend the delay to 99 seconds. Please keep checking the data sync pending list and web order downloading list as this setting may cause big delays.

    We recommend you upgrade your hosting package or change the web host server to improve the performance. A good hosting server should be able to handle thousands of requests per second.

You must be logged in to reply to this topic.