Woo REST API connection error

  • I got a error on Woocommerce REST API test connection.
    I have double checked store URL, Consumer key, and Secrect.
    Every setting is ok but got error msg below

    Error: The remote server returned an error: 401 unauthorized.

    Tried several time with new generated key and secret.
    I also tested wordpress API connection. It is well connected.

    WC version: 3.0.7
    WP version: 4.7.5
    using HTTPS

    Your SSL server does not parse the Authorization header correctly. We have worked around by providing the consumer key/secret as query string parameters instead of the header. Please get the upgrade (download and install WooPOS again), reset API key and try again.

    Another way is to disable https, this is not recommended, but you can try, go to WordPress–>Settings–>General Settings–>Site Address(URL), set URL to http instead of https.

    having same problem 🙁

    Make sure you are running the latest version of WordPress and WooCommerce. If you are still having problems, please email us the details. We’ll check for you.

    All updated still no luck. What detail do you need?

    Can you email us a full screenshot with URL, API Key, and the detailed error message? Send the backend login password if you can.


You must be logged in to reply to this topic.